log in | register | forums
Show:
Go:
Forums
Username:

Password:

User accounts
Register new account
Forgot password
Forum stats
List of members
Search the forums

Advanced search
Recent discussions
- !DualHead puts 2 screens in one (News:)
- RISC OS London Show 2017 - Notes from the talks (News:6)
- November News (News:)
- !Organizer 2.28 reviewed (News:2)
- !OBrowse reviewed (News:10)
- Aemulor (Gen:16)
- DDE reaches release 28 and above (News:)
- Elesar quicks dispels stormy clouds (News:2)
- RISC OS London Show 2017 (News:)
- RISC OS London Show 2017 - Pictures (News:)
Latest postings RSS Feeds
RSS 2.0 | 1.0 | 0.9
Atom 0.3
Misc RDF | CDF
Site Search
 
Article archives
The Icon Bar: Site Comments: Envelopes
 
  Envelopes
  richcheng (09:49 16/4/2007)
  richcheng (09:11 17/4/2007)
    monkeyson2 (09:22 17/4/2007)
      rich (19:24 1/12/2007)
        rich (19:30 1/12/2007)
          rich (19:32 1/12/2007)
 
richard cheng Message #101410, posted by richcheng at 09:49, 16/4/2007

Posts: 653
Did someone do something to the code that makes the little envelopes open when you read a thread?

Today, they seem to be working about as well as before the big redesign, again. I.e. not perfectly, but well enough to be useful.

If, so, thanks!
  ^[ Log in to reply ]
 
richard cheng Message #101438, posted by richcheng at 09:11, 17/4/2007, in reply to message #101410

Posts: 653
Scratch that post. They're hideously broken again now. Must have just been a fluke.
  ^[ Log in to reply ]
 
Phil Mellor Message #101440, posted by monkeyson2 at 09:22, 17/4/2007, in reply to message #101438
monkeyson2Please don't let them make me be a monkey butler

Posts: 12380
If you go to http://www.iconbar.com/forums/?serve=cached the envelopes stay the same.

If you got to http://www.iconbar.com/forums/ (the forums link from the home page) the envelopes are reset.

Does that help?
  ^[ Log in to reply ]
 
Richard Goodwin Message #105540, posted by rich at 19:24, 1/12/2007, in reply to message #101440
Rich
Webmaster
The Icon Bar

Posts: 6765
What I've just done is, if you hit the front of the forums page - even if the "serve=cached" part is on - it'll check how long it has been since your last visit. If it's over three hours, it should update the flags to show new posts since your last visit. Maybe.

Not sure if it'll work, but I guess we'll know when:
* people post more
* I visit the site
* I go away for three hours or more

I doubt people log out very much these days, but I could also make the logout page set the last visit times.
________
RichGCheers,
Rich.
  ^[ Log in to reply ]
 
Richard Goodwin Message #105541, posted by rich at 19:30, 1/12/2007, in reply to message #105540
Rich
Webmaster
The Icon Bar

Posts: 6765
Almost forgot: test.
________
RichGCheers,
Rich.
  ^[ Log in to reply ]
 
Richard Goodwin Message #105542, posted by rich at 19:32, 1/12/2007, in reply to message #105541
Rich
Webmaster
The Icon Bar

Posts: 6765
Nope, it updated instantly. Try again.
________
RichGCheers,
Rich.
  ^[ Log in to reply ]
 

The Icon Bar: Site Comments: Envelopes